+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 5 su 5

Provider microsoft.ace.oledb.12.0 non registrato

  1. #1
    Pacifico437 non è in linea Scolaretto
    Buongiorno,

    con il S.O. Windows 10 64 bit, ho installato Office 2016 in Italiano completo.

    Non ho nessun problema all'Office Word ed Excel mentre ho problema su Access che al salvataggio dati, mi esce la seguente finestra:

    > il provvider microsoft.ace.oledb.12.0 non è registrato nel computer locale.

    Gradirei sapere gentilmente come potrei risolvere.

    Anticipatamente ringrazio e saluto

    Domenico
    Ultima modifica di AntonioG; 26-10-2019 11:50  Motivo: L'oggetto era sbagliato

  2. #2
    Quote Originariamente inviato da Pacifico437 Visualizza il messaggio
    > il provvider microsoft.ace.oledb.12.0 non è registrato nel computer locale.
    E' un errore che è comparso immediatamente dopo l'installazione o hai usato Access tranquillamente per un certo periodo ed ora compare questo?
    E' comparso dopo l'installazione di qualche software in particolare? Del tipo: se usi un punto di ripristino il problema sparisce?
    Prova con una riparazione dell'installazione di Office.
    Specifica quale versione di Win10 e di Office2016. Ormai ad ogni "aggiornamento" le novità di questo tipo sono una costante, sembra.

  3. #3
    Pacifico437 non è in linea Scolaretto
    Gent.mo Phil,

    ringrazio della tempestività e disponibilità.

    Access è la prima volta che lo uso e lo uso abbinato al programma Visual Studio 2019 vb.

    In Access regolarmente ho inserito le intestazioni e l'ho salvato nella cartella del prgramma di Visual Studio ed è salvato con due estensioni (.accdb e .mdb).
    Apro e chiudo regolarmente effettuando qualche modifica al programma Access.
    Il problema è all'inserimento dei dati dal Visual Studio, al salvataggio mi esce la finestra.

    Il S.O. è: Windows 10 Enterprise e regolarmente esegue gli aggiornamenti e Office 2016 64 bit: Microsoft Office Professional Plus 2016.

    Domenico.

  4. #4
    Quote Originariamente inviato da Pacifico437 Visualizza il messaggio
    ..
    Access è la prima volta che lo uso e lo uso abbinato al programma Visual Studio 2019 vb.
    ...
    Apro e chiudo regolarmente effettuando qualche modifica al programma Access.
    Il problema è all'inserimento dei dati dal Visual Studio, al salvataggio mi esce la finestra.
    Qui il problema non è Access ma il sistema che usa Visual Studio per accedere ai file accdb.
    Il primo consiglio potrebbe essere quello di installare il Microsoft Access Database Engine 2016.
    Se questo non risolve (o per approfondire, che fa sempre bene) ti rimando a questo thread, dove l'argomento è stato sviscerato sotto molti aspetti https://www.utteraccess.com/forum/in...ic=2055358&hl=
    Credo comunque che la sezione più adatta per questo thread sia una che riguardi Visual Studio: vb.net o c#, non Access. Chiedi ad un moderatore-amministratore di spostarlo.
    Edit: ecco, il tempo di fare click ed AntonioG ha già disposto.

  5. #5
    Domenico ... il messaggio non dice che Access non è registrato anche perché non ha senso. E' solo il provider non registrato e questo doveva essere il titolo. Inoltre non è un problema di Access ma da inserire nella sezione VB.NET dato che usi il linguaggio VB (Visual Studio è solo l'IDE). Per questo sposto io il thread .... fai attenzione.

    In ogni caso, anche se hai installato Access, installa i driver ACE OLEDB scaricandoli da Microsoft.
    Ultima modifica di AntonioG; 26-10-2019 11:58 
    ℹ️ Leggi di più su AntonioG ...

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Risposte: 4
    Ultimo Post: 18-12-2019, 00:22
  2. Provider microsoft.ace.oledb.12.0 non registrato
    Da Pacifico437 nel forum Microsoft Word
    Risposte: 4
    Ultimo Post: 26-10-2019, 11:47
  3. Microsoft jet oledb 4.0 non registrato sul pc locale
    Da sistemista nel forum Visual Basic .Net
    Risposte: 21
    Ultimo Post: 26-06-2019, 08:36
  4. Risposte: 16
    Ultimo Post: 21-01-2012, 12:07
  5. Risolto: Provider 'Microsoft.ACE.OLEDB.12.0' non è registrato
    Da Nottambulo nel forum Visual Basic .Net
    Risposte: 2
    Ultimo Post: 27-09-2009, 19:37