+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 2 su 2

[Ubuntu] Networking non funzionante dopo migrazione disco

  1. #1
    net-addiction non è in linea Scribacchino
    Buongiorno,
    ho una situazione un po' surreale.
    Ho dovuto spostare un disco con Ubuntu da una macchina ad un'altra. Funziona tutto tranne la rete.

    Se vado nel "network-manager" imposto per il device enp3s0 un IP fisso ma non trovo riscontro con ifconfig.
    Se eseguo "dhclient" lo stesso device prende un IP dal router che, chiaramente, è diverso da quello impostato in network-manager.

    Dopo l'esecuzione di "dhclient" tutto funziona ma al riavvio si ricomincia da capo. Avete idee su come fissare 'sto benedetto IP?

    Grazie,
    ℹ️ Leggi di più su net-addiction ...

  2. #2
    net-addiction non è in linea Scribacchino
    Ho risolto parlandone con un amico.
    Nelle ultime versioni di Ubuntu, la rete viene configurata con netplan grazie ad un file *.yaml in /etc/netplan.
    Quando si fa un'operazione tipo quella che ho fatto io (spostare un disco su un altro pc) il nome dell'interfaccia cambia.

    Banalmente basta verificare ed eventualmente correggere, facendo in modo che il nome dell'interfaccia all'interno del file /etc/netplan/*.yaml sia uguale all'interfaccia che vedete eseguendo
    ifconfig -a
    
    .

    ciao
    ℹ️ Leggi di più su net-addiction ...

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Risposte: 2
    Ultimo Post: 18-01-2017, 12:42
  2. Ubuntu 11: Mouse non funzionante
    Da Cteniza nel forum Tutto Linux
    Risposte: 3
    Ultimo Post: 10-03-2012, 05:43
  3. Risposte: 2
    Ultimo Post: 19-01-2010, 10:15
  4. Risposte: 23
    Ultimo Post: 13-10-2009, 17:39
  5. Ubuntu 8.10: Ethernet non funzionante
    Da Tybyx nel forum Tutto Linux
    Risposte: 8
    Ultimo Post: 30-01-2009, 13:21