Acquista i nostri libri consigliati su Amazon.it
+ Rispondi al messaggio
Pagina 1 di 2 12 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 14

confronta nomi

  1. #1
    L'avatar di dolcissimo
    dolcissimo non  in linea Scribacchino
    Ciao a tutti e complimenti per il nuovo forum molto carino,
    avrei un problemino da risolvere in pratica ho un foglio di excel dove ho una
    tabella con diverse colonne fra cui in una delle colonne scrivo i cognomi.

    Allora quando scrivo un cognome ad esempio PANTALEO nelle altre celle vengono scritti in automatico il nome e tante altre cose, adesso il mio problema che quando scrivo lo stesso cognome nella stessa colonna in un'altra colonna deve scrivere ad esempio "C" invece se il cognome viene scritto per la prima volta deve scrivere "P".
    In pratica se lo scrivo una volta "P" se lo scrivo di nuovo "C"

    Spero di essere stato chiaro!!!!!!!!!

  2. #2
    L'avatar di TheTruster
    TheTruster non  in linea Moderatore Globale Ultimo blog: Mouse Wheel in Visual Basic 6 - ActiveX
    ciao dolcissimo... effettivamente non ho capito molto...

    in pratica la prima volta che scrivi un nome in questo textbox, in un'altro textbox deve apparire P, se lo scrivi per la prima volta, o C se questo nome gi esiste in tabella?

    cos, o non ho capito nulla?

    ma perch si deve fare tutta sta fatica per capire!

    TheTruster
    ℹ️ Leggi di pi su TheTruster ...

  3. #3
    L'avatar di dolcissimo
    dolcissimo non  in linea Scribacchino
    Ciao Truster non proprio cos ma ci sei vicino.
    Allora io non ho texbox io ho un foglio di excel con celle e non textbox!!!
    mi sono creato una tabella con 10 colonne ad esempio;
    numero ordinanza, grado, cognome, nome, tipologia vitto ecc.

    Quando io scrivo un cognome per la prima volta nella cella D125 della colonna cognome, nella colonna tipologia vitto nella cella D125 mi deve scrivere "P",
    se nella stessa colonna e in una diversa cella "D130" scrivo lo stesso cognome, nella colonna tipologia vitto nella cella "D130" si deve scrivere "C"

    Spero di essere stato chiaro stavolta!!!!

  4. #4
    L'avatar di TheTruster
    TheTruster non  in linea Moderatore Globale Ultimo blog: Mouse Wheel in Visual Basic 6 - ActiveX
    beh, forse ad una soluzione si arriva...

    giusto per esempio :
    mettiamo caso che tu inserisca i nomi nella colonna A
    e nella colonna B vuoi le lettere P o C

    sicuramente nella prima riga dell'elenco il nome sar scritto per la prima volta e quindi nella cella B1 metti una bella P

    nella cella B2 metti questa formuletta:

    =SE(A2<>"";SE(VAL.ERRORE(CERCA.VERT(A2;$A$1:A1;1;0 ));"P";"C");"")

    poi la trascini gi fino alla riga che ti serve, riempiendo tutte le righe.
    e dovrebbe andare...

    TheTruster
    ℹ️ Leggi di pi su TheTruster ...

  5. #5
    L'avatar di dolcissimo
    dolcissimo non  in linea Scribacchino
    Ok Truster funziona alla grande!!!!! sei mitico,
    un'altra piccola cosa dopo la seconda volta che si ripete il congnome e scrive "C" tutti gli altri cognomi che vengono scritti dopo deve dare sempre "C" come posso fare?

  6. #6
    L'avatar di TheTruster
    TheTruster non  in linea Moderatore Globale Ultimo blog: Mouse Wheel in Visual Basic 6 - ActiveX
    in pratica se nella colonna delle P e delle C ci sono gi 2 C tutti gli altri nomi inseriti, anche se non presenti prima devono avere C... giusto?

    TheTruster
    ℹ️ Leggi di pi su TheTruster ...

  7. #7
    L'avatar di dolcissimo
    dolcissimo non  in linea Scribacchino
    Si giusto per gi al verificarsi di una "C" tutti gli altri devono essere "C"

  8. #8
    L'avatar di TheTruster
    TheTruster non  in linea Moderatore Globale Ultimo blog: Mouse Wheel in Visual Basic 6 - ActiveX
    =SE(A2<>"";SE(VAL.ERRORE(CERCA.VERT(A2;$A$1:A1;1;0 ));"P";SE(CONTA.SE($B$1:B1;"C")>=1;"P";"C"));"")

    prova a sostituire la formula di prima con questa... e vedi se ha il comportamento che ti serve.

    TheTruster
    ℹ️ Leggi di pi su TheTruster ...

  9. #9
    L'avatar di dolcissimo
    dolcissimo non  in linea Scribacchino
    Purtroppo non funziona!!!!

  10. #10
    L'avatar di TheTruster
    TheTruster non  in linea Moderatore Globale Ultimo blog: Mouse Wheel in Visual Basic 6 - ActiveX
    dolcissimo... scusami, ma gi, devo dire, che con fatica ho capito cosa intendevi quando ti ho dato la prima formula... poi mi dici non funziona, e basta...
    spiegazioni! spiegazioni!
    senza di quelle non capisco cosa deve fare sta benedetta formula!

    spiegami *esattamente* cosa vuoi che succeda... scrivimi un esempio di tabella...

    TheTruster
    ℹ️ Leggi di pi su TheTruster ...

+ Rispondi al messaggio
Pagina 1 di 2 12 ultimoultimo

Potrebbero interessarti anche ...

  1. condizione se in confronta
    Da MARVIN55 nel forum Microsoft Excel
    Risposte: 10
    Ultimo Post: 01-12-2019, 07:15
  2. help per programma che confronta due cartelle
    Da Sn0rky nel forum Pausa caff
    Risposte: 2
    Ultimo Post: 19-05-2016, 09:08
  3. query che confronta le ore
    Da bluigi nel forum Microsoft SQL Server
    Risposte: 11
    Ultimo Post: 28-08-2015, 12:07
  4. [EXCEL] Cerca e confronta
    Da JayS nel forum Microsoft Excel
    Risposte: 1
    Ultimo Post: 05-09-2008, 17:24
  5. confronta file
    Da mafema nel forum Microsoft Word
    Risposte: 2
    Ultimo Post: 03-03-2006, 15:45