+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 4 su 4

Test su due celle per evitare che il risultato nella terza cella sia nullo

  1. #1
    gualtiero non è in linea Novello
    Nella colonna D2 ho un valore così come nella colonna E2 per cui in F2 metto il risultato
    =SE(O(D2="";D2<>"";E2="";E2<>"");(D2-E2);"") ed è tutto OK.
    Se però il valore della colonna D2 è nullo ed è nullo anche il valore della colonna E2, non vorrei nella colonna F2 nessun valore, mentre adesso mi scrive 0,00.
    Grazie anticipatamente

  2. #2
    L'avatar di scossa
    scossa non è in linea Scolaretto
    Quote Originariamente inviato da gualtiero Visualizza il messaggio
    =O(D2="";D2<>"";E2="";E2<>"")
    Questa O() on ha alcun senso perché sarà sempre VERA, visto che D2 (E2) o è uguale a "" o è diverso da "" .......
    ℹ️ Leggi di più su scossa ...

  3. #3
    gualtiero non è in linea Novello
    E' per questo che ho chiesto il vostro contributo perchè la stringa da me scritta non risolve tutti i possibili casi
    Pertanto spero di ricevere la stringa nella forma giusta in modo da poter rendermi conto anch'io dove avevo
    sbagliato
    Grazie anticipatamente

  4. #4
    UGoldrake non è in linea Scolaretto
    Ciao, intendi mica una roba del tipo:
    Se in D2="" e in E2="" allora in F2 metti ""
    Se vuoi questo devi analizzare uno solo tra D2 e E2 (mettiamo D2), valutarne i due casi (D2="" e D2<>"", e nel caso fosse D2="" allora valuti l'altro.
    Quindi devi fare 2 SE, il secondo nidificato nel caso D2="".
    Chiaro?
    In parole povere SE D2="" allora valuta E2, SE E2="" allora F2="" Altrimenti F2 = D2 + E2
    Ora dovresti essere in grado di tradurlo in formula.
    Ciao. Ugo.

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Risultato diverso tra sub e risultato cella
    Da schwarz89it nel forum Microsoft Excel
    Risposte: 3
    Ultimo Post: 27-09-2014, 12:05
  2. Risposte: 0
    Ultimo Post: 10-07-2014, 15:42
  3. Inserire in una cella il testo di piu celle che contengono la stessa porzione di test
    Da pinobello nel forum LibreOffice, OpenOffice e altro
    Risposte: 2
    Ultimo Post: 15-05-2014, 14:53
  4. Risposte: 4
    Ultimo Post: 05-11-2013, 17:45
  5. Inserire una userform nella terza pagina di un foglio attivo di excel
    Da DOMENICO_FALCO nel forum Microsoft Excel
    Risposte: 9
    Ultimo Post: 20-08-2013, 18:52