Acquista i nostri libri consigliati su Amazon.it
+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 4 su 4

Sequenza di Fibonacci

  1. #1
    igor90 non  in linea Novello
    Post
    6
    Like Inviati  
    0
    Like Ricevuti  
    0
    Ciao a tutti, oggi ho cominciato un progettino, in pratica volevo creare una funzione che dati due numeri di tipo intero in input dia in output la successione di Fibonacci partendo dai dati di input. Inoltre volevo dichiarare una variabile k, che indica una posizione i-esima all'interno della successione e che restituisca l'elemento Nk.
    Secondo voi come dovrei agire? Dovrei dichiarare delle funzioni temporanee e utilizzare un ciclo?

  2. #2
    L'avatar di @Alex
    @Alex non  in linea Moderatore Globale
    Post
    16,804
    Like Inviati  
    0
    Like Ricevuti  
    23
    Non si capisce se la devi fare da codice o ti basta una cosa che funziona senza complicazione...
    Nel 2 Caso questo rappresenta lo sviluppo della sequenza di Fibonacci:
    A1: 1
    A2: 1
    A3:=SOMMA($A1:$A2)
    
    Ovviamente trascina A3 in basso fino a quanto ritieni opportuno.

    Se vuoi crearla da codice... direi che la logica la medesima ovviamente dovrai cilcare dal 3 elemento in quanto i primi 2 sono sempre=1
    Public Sub Fibonacci(indice As Long, Optional Column as Long=1)
    
        Dim lngCellPointer As Long
        Dim sh As Worksheet
       
        Set sh = ThisWorkbook.Worksheets("Foglio1")
       
        With sh
            .Cells(1, Column).Value = 1
            .Cells(2, Column).Value = 1
            For lngCellPointer = 3 To indice
                .Cells(lngCellPointer,Column).Value = .Cells(lngCellPointer - 2,Column).Value + .Cells(lngCellPointer - 1,Column).Value
            Next
        End With
       
        Set sh = Nothing
       
    End Sub
    
    dove Indice il numero Limite della serie... il Parametro Optional la COLONNA in questo caso usiamo di Optional "A"...
    Ultima modifica di @Alex; 16-10-2012 23:34 
    ℹ️ Leggi di pi su @Alex ...

  3. #3
    igor90 non  in linea Novello
    Post
    6
    Like Inviati  
    0
    Like Ricevuti  
    0
    Ok grazie, volevo sapere come fare via codice, comunque mi stavo domandando se poteva essere fatta la stessa cosa usando solo funzioni temporanee tipo tmp e cicli del tipo for ... to

  4. #4
    L'avatar di @Alex
    @Alex non  in linea Moderatore Globale
    Post
    16,804
    Like Inviati  
    0
    Like Ricevuti  
    23
    Puoi darci delucidazioni tecniche su cosa intendi per funzioni "temporanee tipo tmp"....?
    Per la parte cicli FOR...TO... hai guardato il codice...? C' proprio quella, riguarda ora l'ho evidenziata in ROSSO magari si vede meglio...!!!
    ℹ️ Leggi di pi su @Alex ...

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Risposte: 1
    Ultimo Post: 15-01-2018, 16:49
  2. Sequenza BBA
    Da maxpix nel forum Altri linguaggi e strumenti
    Risposte: 0
    Ultimo Post: 06-06-2014, 12:26
  3. Generatore di fibonacci ritardato
    Da drew nel forum C/C++
    Risposte: 1
    Ultimo Post: 21-10-2012, 13:01
  4. [javascript] fibonacci string
    Da ash41 nel forum HTML, CSS e JavaScript
    Risposte: 4
    Ultimo Post: 16-09-2010, 11:34
  5. Risposte: 7
    Ultimo Post: 14-10-2007, 21:29