+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 5 su 5

Problema leggere solo celle filtrate.

  1. #1
    _pierpaolo non è in linea Novello
    Devo leggere solo le celle filtrate.
    Inserisco direttamente il foglio excel, le celle interessate sono quelle che contengono SOMMA.PIU.SE e MEDIA.PIU.SE.
    Queste celle fanno riferimento al foglio "Copia Foglio 1", ma avrei la necessità che leggessero appunto solo le celle filtrate.

    Posto direttamente il foglio interessato:

    http://www.pointerdata.it/images/paolo/prove.xlsx

    Grazie

  2. #2
    ricky53 non è in linea Scribacchino
    Ciao,
    per poterti aiutare c'è bisogno di maggiori spiegazioni.
    Il file è molto utile però si deve avere la chiarezza delle tue necessità.
    Per esempio cosa intendi con "... avrei la necessità che leggessero appunto solo le celle filtrate" ???
    ℹ️ Leggi di più su ricky53 ...

  3. #3
    _pierpaolo non è in linea Novello
    Ecco, le celle che contengono le funzioni SOMMA.PIU.SE e CONTA.PIU.SE fanno riferimento al foglio denominato "Copia foglio 1".
    A me interessa filtrare questo foglio per escludere tutta una serie di righe.

    Vorrei quindi che le formule di cui sopra elaborassero SOLO le righe che non ho escluso, cioè quelle visibili.

  4. #4
    ricky53 non è in linea Scribacchino
    Ciao,
    a mia conoscenza con queste funzioni non è possibile.
    Utilizzando del codice VBA scritto appositamente si può fare.

    Come te la cavi con il VBA?

    Puoi inviarci le condizioni di filtratura e ... ne discutiamo per capire come operare.
    ℹ️ Leggi di più su ricky53 ...

  5. #5
    _pierpaolo non è in linea Novello
    In un altro forum un utente mi ha dato la soluzione, però, come da lui stesso anticipato, i calcoli sono troppo onerosi per il processore.
    Infatti ho provato, il meccanismo funziona perfettamente, ma i tempi di risposta sono di oltre 5 minuti.
    Sotto ti invio la soluzione proposta.
    Io devo poter filtrare per tutti i filtri che vedi applicati nell'immagine.

    --------------------------------------------------------------------------------------------
    Risposta
    Ciao,

    in B3 (preferisco usare come media somma/conta)

    =SE(L3>=$T$1;MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCART O('Copia foglio1'!E:E;RIF.RIGA(A:A)-MIN(RIF.RIGA(A:A));;1));--('Copia foglio1'!$K:$K=B$2);--('Copia foglio1'!$L:$L=$A3))/MATR.SOMMA.PRODOTTO(SUBTOTALE(3;SCARTO('Copia foglio1'!E:E;RIF.RIGA(A:A)-MIN(RIF.RIGA(A:A));;1));--('Copia foglio1'!$K:$K=B$2);--('Copia foglio1'!$L:$L=$A3));0)

    in L3

    =MATR.SOMMA.PRODOTTO(SUBTOTALE(3;SCARTO('Copia foglio1'!A:A;RIF.RIGA(A:A)-MIN(RIF.RIGA(A:A));;1));--('Copia foglio1'!$K:$K=L$2);--('Copia foglio1'!$L:$L=$K3))

    Le formule sono molto impegnative per il processore, anche riducendo i riferimenti.

    =MATR.SOMMA.PRODOTTO(SUBTOTALE(3;SCARTO('Copia foglio1'!$A$1:$A$10000;RIF.RIGA($A$1:$A$10000)-MIN(RIF.RIGA($A$1:$A$10000));;1));--('Copia foglio1'!$K$1:$K$10000=L$2);--('Copia foglio1'!$L$1:$L$10000=$K6))

    Spero sia d'aiuto
    ---------------------------------------------------------------------------------------------

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. riferimento a celle filtrate (Excel 2007)
    Da Lindo nel forum Microsoft Excel
    Risposte: 2
    Ultimo Post: 10-07-2020, 17:14
  2. macro per selezionare celle filtrate excel
    Da battinato nel forum Microsoft Excel
    Risposte: 3
    Ultimo Post: 27-06-2008, 22:00
  3. XML leggere solo alcuni campi
    Da skiokk nel forum Visual Basic .Net
    Risposte: 4
    Ultimo Post: 20-04-2007, 21:08
  4. selezionare celle filtrate
    Da jacknice nel forum Microsoft Word
    Risposte: 1
    Ultimo Post: 29-05-2006, 21:09
  5. Risposte: 4
    Ultimo Post: 29-08-2005, 18:32