Acquista i nostri libri consigliati su Amazon.it
+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 7 su 7

Numeri precedenti e successivi

  1. #1
    supergiu non  in linea Novello
    Post
    3
    Like Inviati  
    0
    Like Ricevuti  
    0
    Salve a tutti ragazzi,
    ecco il mio quesito:

    - Ho una colonna di numeri (ad esempio 100, 200 , 300, 400 ecc)
    - Ho un casella (A1) contenente un numero (ad esempio 120)

    Vorrei mostrare nella casella A2 il numero 100, ovvero il precedente di 120, e nelle casella A3 200, ovvero il successivo.

    Come potrei fare?

    Grazie a tutti
    Ultima modifica di AntonioG; 10-09-2015 18:36 

  2. #2
    alfrimpa non  in linea Scolaretto
    Post
    332
    Like Inviati  
    0
    Like Ricevuti  
    0
    Ciao Supergiu.

    Non so se ho capito bene il tuo quesito.

    Non c' bisogno di avere una colonna di appoggio con i valori

    Supponendo che in A1 ci sia il numero per avere quello precedente in altra cella scrivi

    =ARROTONDA.DIFETTO(A1;100)
    
    e per quello successivo

    =ARROTONDA.ECCESSO(A1;100)
    
    Alfredo

  3. #3
    supergiu non  in linea Novello
    Post
    3
    Like Inviati  
    0
    Like Ricevuti  
    0
    Mmmmm no, non questo quello che intendevo. Cerco di spiegarlo in un altro modo

    Nella cella A1 c' il numero di giri teorico (calcolata mediante una formula), tuttavia nella realt bisogna usare il numero di giri che il macchinario supporta.
    Quindi io nella mia colonna dei valori inserir tutti i numeri dio giri (reali) supportati dal macchinario.

    Quello che mi serve mostrare in altre due colonne i due numeri di giri reali (quelli precedenti e quella successivi) a quelli teorici

    Esempio (dove ho inserito manualemente "n eff(dif)" e "n eff(ecc)" in base ad una tabella con tutti numeri di giri supportati dalla macchina)


    Elenco n giri macchinario:

  4. #4
    Marius44 non  in linea Scolaretto
    Post
    360
    Like Inviati  
    0
    Like Ricevuti  
    5
    Devi innanzi tutto inserire nella colonna a fianco a "Elenco n giri macchinario" lo stesso elenco ma CAPOVOLTO. Quindi nella cella dove vuoi il risultato per difetto inserisci
    =CERCA(B4;$G$4:$G$21)
    
    dove B4 il dato da cercare, l'intervallo G4:G21 il riferimento al tuo "Elenco n giri macchinario". Nella cella dove vuoi il risultato per eccesso inserisci
    =INDICE($H$4:$H$21;CONFRONTA(B4;$H$4:$H$21;-1);)
    
    dove l'intervallo H4:H21 l'elenco CAPOVOLTO, B4 il dato da cercare.

    Prova e fammi sapere. Ciao,
    Mario

  5. #5
    supergiu non  in linea Novello
    Post
    3
    Like Inviati  
    0
    Like Ricevuti  
    0
    Quote Originariamente inviato da Marius44 Visualizza il messaggio
    Devi innanzi tutto inserire nella colonna a fianco a "Elenco n giri macchinario" lo stesso elenco ma CAPOVOLTO. Quindi nella cella dove vuoi il risultato per difetto inserisci
    =CERCA(B4;$G$4:$G$21)
    
    dove B4 il dato da cercare, l'intervallo G4:G21 il riferimento al tuo "Elenco n giri macchinario". Nella cella dove vuoi il risultato per eccesso inserisci
    =INDICE($H$4:$H$21;CONFRONTA(B4;$H$4:$H$21;-1);)
    
    dove l'intervallo H4:H21 l'elenco CAPOVOLTO, B4 il dato da cercare.

    Prova e fammi sapere. Ciao,
    Mario
    Grazie mille!!!!!!

    Funziona alla grande

  6. #6
    L'avatar di scossa
    scossa non  in linea Scolaretto
    Post
    183
    Like Inviati  
    0
    Like Ricevuti  
    0
    Quote Originariamente inviato da Marius44 Visualizza il messaggio
    Devi innanzi tutto inserire nella colonna a fianco a "Elenco n giri macchinario" lo stesso elenco ma CAPOVOLTO.
    Secondo me superfluo.

    Elenco numero giri macchinario in G1:G18
    n giri teorico in A1

    in A2: =INDICE($G$1:$G$18;CONFRONTA(A1;$G$1:$G$18))

    in A3: =INDICE($G$1:$G$18;CONFRONTA(A1;$G$1:$G$18)+1)
    ℹ️ Leggi di pi su scossa ...

  7. #7
    Marius44 non  in linea Scolaretto
    Post
    360
    Like Inviati  
    0
    Like Ricevuti  
    5
    @scossa
    Come sempre, hai ragione. Mi ero fermato alla ... prima osteria.
    Ciao,
    Mario

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Autocompilazione campi successivi tabella complessa
    Da w_barone nel forum Microsoft Access
    Risposte: 2
    Ultimo Post: 20-03-2018, 22:56
  2. [ACCESS] media progressiva degli N records precedenti
    Da valter nel forum Microsoft Access
    Risposte: 2
    Ultimo Post: 18-03-2014, 19:47
  3. Risposte: 3
    Ultimo Post: 12-06-2013, 18:36
  4. Risposte: 1
    Ultimo Post: 11-06-2013, 23:50
  5. Risposte: 14
    Ultimo Post: 18-02-2011, 09:15