Acquista i nostri libri consigliati su Amazon.it
+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 8 su 8

Non visualizzare valori pari a 0 in un grafico

  1. #1
    Kama non  in linea Novello
    Post
    3
    Like Inviati  
    0
    Like Ricevuti  
    0
    Buongiorno,

    vi chiedo aiuto per un problema apparentemente banale che non riesco per a risolvere.

    Ho un grafico a dispersione con 2 colonne di dati in asse X e Y. Questi dati sono dinamici e dunque provengono da formule che cambiano in base a cosa seleziono in un menu a tendina. Vorrei chiedervi come non visualizzare nel relativo grafico quei dati che in base alla selezione del menu a tendina sono pari a 0 (in realt non visualizzati in quanto parte della formula SE.NON.DISP.), al momento infatti compaiono e riempiono il grafico di puntini inutili.

    Vi ringrazio molto in anticipo per l'aiuto


  2. #2
    Marius44 non  in linea Scolaretto
    Post
    355
    Like Inviati  
    0
    Like Ricevuti  
    4
    Ciao
    Una soluzione potrebbe essere la seguente:
    =Se(tua_formula=NON.DISP();NON.DISP();tua_formula)
    cio se il risultato della tua formula NON.DISP allora mettimi NON.DISP altrimenti metti il risultato della tua formula.

    Ciao,
    Mario

  3. #3
    Kama non  in linea Novello
    Post
    3
    Like Inviati  
    0
    Like Ricevuti  
    0
    Quote Originariamente inviato da Marius44 Visualizza il messaggio
    Ciao
    Una soluzione potrebbe essere la seguente:
    =Se(tua_formula=NON.DISP();NON.DISP();tua_formula)
    cio se il risultato della tua formula NON.DISP allora mettimi NON.DISP altrimenti metti il risultato della tua formula.

    Ciao,
    Mario
    Grazie per la risposta Mario,

    anche nella mia formula precedente i valori uguali a zero non venivano visualizzati

    Il problema che il grafico invece me li include, andando a "intasare" la visualizzazione.

    Cercavo infatti un metodo per escludere i valori non disponibili ("vuoti") dal grafico, pi che dalla tabella.

  4. #4
    GiuseppeMN non  in linea Scribacchino
    Post
    786
    Like Inviati  
    0
    Like Ricevuti  
    1
    Buona giornata @Marius44 e un saluto a @Kama;
    ovviamente sbaglio io ma, supponendo che in colonna "B" abbia dei Vaolri numerici alternati dalla Stringa "NON.DISP" la Formula:
    =SE($B1=NON.DISP();NON.DISP();$B1)
    copiata nelle Celle sottostanti rende un grafico senza alcun valore.

    Diversamente utilizzando la Formula
    =SE($B1="NON.DISP";NON.DISP();$B1)
    copiata nelle Celle sottostanti rende un grafico corretto senza riportare i Valori uguali a 0 (Zero).

    Nome:   Non visualizzare valori pari a 0 in un grafico.png
Visite:  15
Grandezza:  81.3 KB

    Dove sbaglio?

    Grazie dell'attenzione che potrai dedicarmi.


    Giuseppe

  5. #5
    Kama non  in linea Novello
    Post
    3
    Like Inviati  
    0
    Like Ricevuti  
    0
    Quote Originariamente inviato da GiuseppeMN Visualizza il messaggio
    Buona giornata @Marius44 e un saluto a @Kama;
    ovviamente sbaglio io ma, supponendo che in colonna "B" abbia dei Vaolri numerici alternati dalla Stringa "NON.DISP" la Formula:
    =SE($B1=NON.DISP();NON.DISP();$B1)
    copiata nelle Celle sottostanti rende un grafico senza alcun valore.

    Diversamente utilizzando la Formula
    =SE($B1="NON.DISP";NON.DISP();$B1)
    copiata nelle Celle sottostanti rende un grafico corretto senza riportare i Valori uguali a 0 (Zero).

    Allegato 2664

    Dove sbaglio?

    Grazie dell'attenzione che potrai dedicarmi.


    Giuseppe
    Ciao Giuseppe,

    il secondo grafico sarebbe esattamente il mio obiettivo, quello di vedere rappresentati sul grafico soltanto i dati presenti in tabella, escludendo man mano i vari non disponibili. Non riesco per a vedere le differenze in termini di formule dei due grafici. Riusciresti ad approfondire?

    Ti ringrazio in anticipo!

    Marco

  6. #6
    GiuseppeMN non  in linea Scribacchino
    Post
    786
    Like Inviati  
    0
    Like Ricevuti  
    1
    Buona giornata @Kama;
    la differenza fra le due Formule consiste nella definizione della condizione:
    =SE($B1=NON.DISP();NON.DISP();$B1)
    
    in questa Formula la condizione NON.DISP()

    Diversamente utilizzando la Formula
    =SE($B1="NON.DISP";NON.DISP();$B1)
    
    la condizione "NON.DISP"


    A disposizione.

    Giuseppe

  7. #7
    Marius44 non  in linea Scolaretto
    Post
    355
    Like Inviati  
    0
    Like Ricevuti  
    4
    Ciao a tutti
    Ovviamente GiuseppeMN (un caro saluto) ha ragione!

    Ciao,
    Mario

  8. #8
    GiuseppeMN non  in linea Scribacchino
    Post
    786
    Like Inviati  
    0
    Like Ricevuti  
    1
    Buon pomeriggio Mario.
    Grazie del riscontro; in ogni caso bene considerare che l'dea iniziale stata tua io, molto indegnamente, me ne sono appropriato adattandola alla richiesta di @Kama.


    Giuseppe

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Nascondere valori su grafico a torta nel report...
    Da terrornoize nel forum Microsoft Access
    Risposte: 5
    Ultimo Post: 26-04-2015, 18:57
  2. visualizzare valore dati grafico al passaggio del mouse
    Da cilosrip nel forum Visual Basic .Net
    Risposte: 7
    Ultimo Post: 12-04-2014, 10:35
  3. problema con macro per visualizzare grafico e filtro dati
    Da Paolo84 nel forum Microsoft Excel
    Risposte: 1
    Ultimo Post: 18-05-2012, 22:59
  4. Aggiornare tabelle pari-pari access
    Da AlbiCodex nel forum Microsoft Access
    Risposte: 8
    Ultimo Post: 04-11-2009, 08:20
  5. VB6 - Valori dell'asse Y di un grafico.
    Da Louis nel forum Visual Basic 6
    Risposte: 4
    Ultimo Post: 27-10-2006, 08:41