Acquista i nostri libri consigliati su Amazon.it
+ Rispondi al messaggio
Pagina 1 di 3 123 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 27

Estrarre elenco univoci

  1. #1
    paoņerrai non č in linea Novello
    Post
    26
    Like Inviati  
    0
    Like Ricevuti  
    0
    Buongiorno,
    vorrei estrarre da un elenco i valori univoci.
    Vorrei ottenere ciņ tramite formula non matriciale.
    Mi potreste aiutare? Grazie

  2. #2
    Marius44 non č in linea Scolaretto
    Post
    355
    Like Inviati  
    0
    Like Ricevuti  
    4
    Ciao
    Se non vado errato occorre dare una lettura a questo link
    Ti riporto il secondo paragrafo
    A partire dall'aggiornamento di 2018 di settembre per Microsoft 365, tutte le formule che possono restituire pił risultati verranno automaticamente riversate in basso o in celle adiacenti. Questa modifica del comportamento č accompagnata anche da diverse nuove funzioni di matrice dinamica. Le formule di matrice dinamica, che usano funzioni esistenti o le funzioni di matrice dinamica, devono essere immessesolo in una singola cella, quindi confermate premendo INVIO. In precedenza, le formule di matrice legacy richiedono prima di tutto l'intervallo di output, quindi conferma la formula con CTRL + MAIUSC + INVIO. Si chiama comunemente formule CSE .
    Ciao,
    Mario

  3. #3
    paoņerrai non č in linea Novello
    Post
    26
    Like Inviati  
    0
    Like Ricevuti  
    0
    Ti ringrazio.. Ma io vorrei una formula non matriciale

  4. #4
    L'avatar di AntonioG
    AntonioG non č in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Post
    17,369
    Blogs
    5
    Like Inviati  
    5
    Like Ricevuti  
    31
    Non č possibile. Semmai con vba
    ℹ️ Leggi di pił su AntonioG ...

  5. #5
    paoņerrai non č in linea Novello
    Post
    26
    Like Inviati  
    0
    Like Ricevuti  
    0
    OK ti ringrazio

  6. #6
    GiuseppeMN non č in linea Scribacchino
    Post
    786
    Like Inviati  
    0
    Like Ricevuti  
    1
    Un saluto a Tutti.

    Leggo solo ora.
    Molto probabilmente ho male interpretato la richiesta ma assumendo di avere un elenco nel Range A3:A190, lasciando la Cella "C2" vuota, nella Cella "C3" proverei a scrivere la Formula:
     =SE.ERRORE(INDICE(A$3:A$190;CONFRONTA(0;INDICE(CONTA.SE(C$2:C2;A$3:A$190&""););0));"")
    
    da copiare nelle Celle sottostanti.


    A sisposizione.

    Giuseppe

    P.s. Credo opportuno allegare l'immagine della Formula in quanto, nel TAG, alcuni caratteri vengono falsati.

    Nome:   Formula.png
Visite:  9
Grandezza:  2.1 KB
    Ultima modifica di GiuseppeMN; 26-09-2020 01:09  Motivo: Aggiunta immagine

  7. #7
    paoņerrai non č in linea Novello
    Post
    26
    Like Inviati  
    0
    Like Ricevuti  
    0
    Ti ringrazio... Ho inserito la formula in una cella ma mi dą il messaggio d'errore "valore"

  8. #8
    Marius44 non č in linea Scolaretto
    Post
    355
    Like Inviati  
    0
    Like Ricevuti  
    4
    Buongiorno a tutti
    Dopo i doverosi e meritati complimenti a GiuseppeMN aggiungo per il richiedente che la formula č quella dell'immagine e, come detto da Giuseppe, va copiata in tutte le celle dell'intervallo iniziando dalla cella C2.
    Posto la formula quotando - occorre eliminare lo spazio in questo punto &""); );0));"")
    =SE.ERRORE(INDICE(A$3:A$190;CONFRONTA(0;INDICE(CON TA.SE(C$2:C2;A$3:A$190&""); );0));"")
    Ciao,
    Mario

  9. #9
    paoņerrai non č in linea Novello
    Post
    26
    Like Inviati  
    0
    Like Ricevuti  
    0
    Ti ringrazio...
    Ora non mi dą pił l'errore ma non vengono estrapolati i dati univoci dall'elenco. La c3 e le celle sottostanti dove ho copiato la formula rimangono vuote

  10. #10
    Marius44 non č in linea Scolaretto
    Post
    355
    Like Inviati  
    0
    Like Ricevuti  
    4
    Ciao
    L'elenco dei dati č nell'intervallo A3:A190? La cella C2 č vuota?
    Puoi precisare di che tipo di dati si tratta. Io ho fatto la prova con un elenco di dati numerici e alfabetici mischiati e il risultato č quello richiesto.

    Ciao,
    Mario

+ Rispondi al messaggio
Pagina 1 di 3 123 ultimoultimo

Potrebbero interessarti anche ...

  1. Risposte: 6
    Ultimo Post: 20-06-2018, 16:00
  2. Generatore Codici univoci
    Da lele710 nel forum Microsoft Excel
    Risposte: 12
    Ultimo Post: 07-12-2015, 04:41
  3. Valori univoci in combobox
    Da GianlucaM nel forum Visual Basic .Net
    Risposte: 1
    Ultimo Post: 06-12-2011, 15:16
  4. Vb net - Excel campi univoci
    Da alex__ice nel forum Visual Basic .Net
    Risposte: 9
    Ultimo Post: 24-11-2008, 09:21
  5. Estrarre e raggruppare dati da elenco Excel
    Da forio nel forum Microsoft Excel
    Risposte: 1
    Ultimo Post: 12-12-2007, 09:16