+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 3 su 3

Data odierna in Cella

  1. #1
    brace non è in linea Novello
    Buonasera. Trovo qualcuno che saprebbe darmi una coretta informazione su una formula di Excel. Ultimamente, o io ho qualche "momento opaco" oppure qualcosa é cambiato. Esempio Inserisco in una cella di Excel supponiamo A1 =oggi(). Il sistema mi darà la data odierna. Dipende poi da me come formattare la data. Supponiamo poi che nella cella A2 inserisca sempre oggi() formattato come gggg (vale a dire come cella formattata in maniera "personalizzato") ossia ricapitolando A1= 14/05/12 A2=lunedì. Ora se io creo una formula nella cella A3 e utilizzo la funzione (SE) trovo questa stranezza. =Se(A2="Lunedì";A2-3;A2-4) è solo un esempio, Il risultato dovrebbe essere a parer mio 14/5-3=11/5 vale a dire venerdì ciò che trovo strano é che usando la paletta della formula "fx" il sistema mi dice che é FALSO. In realtà il risultato non sarà venerdì, ma giovedì. E' quindi qui che chiedo aiuto a qualcuno che ne sappia più di me. Se é vero come é vero che oggi() é "lunedì", perché il sistema dice che é FALSO? Ovviamente questo tipo di risposta falsa tutto il contenuto del mio risultato. O devo ritenere che la formattazione di oggi() sia diversa? Oppure più semplicemente sbaglio formula. Perdonate se sono stato un po contorto.
    Grazie a chi saprà aiutarmi. E buona serata
    Brace

  2. #2
    L'avatar di Zer0Kelvin
    Zer0Kelvin non è in linea Scolaretto
    Ciao.
    La data, anche se formattata in modo da sembrare un testo, è sempre un numero.
    La formula corretta è
    =SE(GIORNO.SETTIMANA(A2;2)=1;A2-3;A2-4)
    
    dove
    1=lunedì
    2=martedì
    ecc...

  3. #3
    brace non è in linea Novello
    Grazie (zerokelvin) Novello
    Non conosco la funzione giorno.settimana. Cercherò di capirla meglio. Perdona non sono così scafato. Ho visto la formula devo comprendere meglio come applicarla. Ringrazio molto per ora. Okkidoki
    Brace

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Data odierna in maschera access
    Da axo nel forum Microsoft Access
    Risposte: 7
    Ultimo Post: 27-09-2008, 19:24
  2. [mschart] visualizzare conteggio per la data ODIERNA
    Da martin nel forum Visual Basic 6
    Risposte: 1
    Ultimo Post: 21-08-2008, 19:30
  3. calendario con data odierna
    Da martin nel forum Visual Basic 6
    Risposte: 9
    Ultimo Post: 26-07-2008, 12:51
  4. Excel - Inserire data odierna
    Da Michelangelo nel forum Microsoft Excel
    Risposte: 1
    Ultimo Post: 22-04-2006, 14:52
  5. problema inserimento data odierna
    Da kaste81 nel forum ASP 3, ASP .Net
    Risposte: 3
    Ultimo Post: 07-12-2005, 17:21