+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 3 su 3

Contare le Celle che iniziano con un certo carattere

  1. #1
    GiuseppeMN non è in linea Scribacchino
    Buona giornata a Tutti.

    Ho due Fogli di lavoro:
    - Dati
    - Report
    In Dati ho una struttura di questo tipo:
    BF4 = 01/001
    BF5 = 01/003
    BF6 = 02/001
    BF7 = 01/002
    BF8 = 03/001
    .
    .
    .
    BF300 = 01/140

    In Report ho una struttura di questi tipo:
    P19 = 01
    P20 = 02
    P21 = 03

    In Report, per contare quanti Record in Dati iniziano con 01, 02 o 03 in Q19 e nelle Celle sottostanti utilizzo la Formula:

    =MATR.SOMMA.PRODOTTO((Dati!$BF$4:$BF$300 <> "")*(SINISTRA(Dati!$BF$4:$BF$300;2)=$P19))

    Come potrei strutturare la Funzione CONTA.SE senza utilizzare la struttura Matriciale per ottenere lo stesso risultato?

    Grazie in anticipo.


    Giuseppe

  2. #2
    L'avatar di @Alex
    @Alex non è in linea Moderatore Globale
    Non so ho capito bene... ho provato questa e da un certo risultato
    =CONTA.SE(Dati!$BF$4:$BF$300;CONCATENA($P19;"*"))
    
    Saluti
    ℹ️ Leggi di più su @Alex ...

  3. #3
    GiuseppeMN non è in linea Scribacchino
    Buona giornata @Alex;
    leggo solo ora.

    La formula che proponi mi sembra una soluzione ottimale.


    Grazie.

    Giuseppe

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Selezione di un certo numero di celle
    Da Giovanni68 nel forum Microsoft Excel
    Risposte: 2
    Ultimo Post: 03-11-2017, 11:26
  2. [C] Contare occorrenze carattere in stringa
    Da machopicho nel forum C/C++
    Risposte: 16
    Ultimo Post: 22-09-2013, 10:25
  3. Risposte: 1
    Ultimo Post: 23-02-2013, 15:17
  4. contare celle colorate
    Da aligorio2001 nel forum Presentati
    Risposte: 1
    Ultimo Post: 06-07-2010, 22:14
  5. contare le celle con excel
    Da stellina119 nel forum Microsoft Excel
    Risposte: 11
    Ultimo Post: 12-05-2009, 12:55