Acquista i nostri libri consigliati su Amazon.it
+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 5 su 5

Mancano le relazioni dopo lo splitting del DB

  1. #1
    ubi
    ubi non è in linea Novello
    Buongiorno a tutti!

    sto eseguendo lo split del DB in front_end e back_end, ma purtroppo mi accorgo che mancano le relazioni tra le tabelle nel front_end solo al livello di visualizzazione (vedere foto) perche di fatto tutto resto funziona (ad un primo test veloce). Nel back_end invece non ha problemi, le tabelle e le relazioni sono corretti.
    Piu precisamente nel front_end solo una tabella ha mantenuto la visualizzazione corretta (pic1) mentre per tutti gli altri non è riuscito a farlo il che mi porta a pensare a qualche bug?

    Ho provato a fare lo split sia con il wizard che in modo manuale (creare due file nuovi e importare su uno solo le tabelle e sul altro DB il resto dei form,report, etc per poi linkare le tabelle) ma in entrambi i casi hanno prodotto questo risultato.
    Ho provato a cancellare e ricreare le relazioni nel back_end ma senza successo.
    Qualcuno ha idea di cosa possa essere ?

    pic1
    https://ibb.co/stZRgDk

    pic2
    https://ibb.co/CHWLvVv

  2. #2
    L'avatar di @Alex
    @Alex non è in linea Moderatore Globale
    Non hai pensato che sia normale....?
    Le relazioni sono oggetti che risiedono nel server, quindi le linked table sono solo una forma di visualizzazione del link alle tabelle, quindi risulta non sensato avere le relazioni clienti side.
    ℹ️ Leggi di più su @Alex ...

  3. #3
    ubi
    ubi non è in linea Novello
    probabilmente non mi sono spiegato bene, cmq la soluzione sta nella proprietà SubDataSheets che è settato in [auto] che sembra non funzionare bene dopo lo split, e quindi tocca assegnarlo in modo manuale per ogni tabella ma almeno cosi funziona.

  4. #4
    Quote Originariamente inviato da ubi Visualizza il messaggio
    probabilmente non mi sono spiegato bene, cmq la soluzione sta nella proprietà SubDataSheets che è settato in [auto]
    C'è anche chi suggerisce di impostare a [None] (English, of course) quella proprietà a beneficio delle prestazioni.
    https://www.fmsinc.com/microsoftacce...ataSheetNameID

  5. #5
    ubi
    ubi non è in linea Novello
    Grazie per il suggerimento!

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Stampa unione da query filtrata: mancano alcuni parametri
    Da Comune Massaro nel forum Microsoft Access
    Risposte: 16
    Ultimo Post: 09-10-2014, 08:37
  2. Risposte: 8
    Ultimo Post: 02-03-2012, 13:12
  3. Risolto: VB 2008 in WPF alcune proprietà mancano
    Da SalCodi nel forum Visual Basic .Net
    Risposte: 4
    Ultimo Post: 27-08-2010, 12:25
  4. Risposte: 3
    Ultimo Post: 30-04-2009, 07:23
  5. Gestire i dati tramite USB (mancano le rs232)
    Da kobra24 nel forum Visual Basic .Net
    Risposte: 1
    Ultimo Post: 10-12-2005, 00:02