Acquista i nostri libri consigliati su Amazon.it
+ Rispondi al messaggio
Visualizzazione dei risultati da 1 a 6 su 6

Macro autokeys non funzionante

  1. #1
    mailman_1969 non è in linea Scolaretto
    Post
    74
    Like Inviati  
    0
    Like Ricevuti  
    0
    Buongiorno,
    in un database Access ho creato la macro in oggetto in cui ho assegnato ad alcuni tasti funzione (F9-F10) alcune funzioni rapide di filtro dei dati in una maschera. Inizialmente funzionava tutto correttamente, ma da un po' di tempo mi da errore che non trova i campi della maschera. Esce la finestra popup con scritto per esempio: "Nessun campo con nome 'Note_3' nel record corrente" (a volte da anche errore per campo 'Commessa_2'. Ma il campo esiste nella maschera.
    La macro associata al tasto F9 e' strutturata nel modo seguente:
    - Vai al controllo 'Commessa_2'
    - Filtro in base a selezione
    - Vai a controllo 'ID'
    - Esegui comando Ordinedecrescente
    - Vai a controllo 'Note_3'
    Qualche suggerimento?
    Puo' essere dovuto ad un aggiornamento automatico di Access?
    Grazie in anticipo

  2. #2
    L'avatar di @Alex
    @Alex non è in linea Very Important Person
    Post
    16,743
    Like Inviati  
    0
    Like Ricevuti  
    18
    Hai abilitato la proprietà KEYPREVIEW nella maschera...?
    ℹ️ Leggi di più su @Alex ...

  3. #3
    mailman_1969 non è in linea Scolaretto
    Post
    74
    Like Inviati  
    0
    Like Ricevuti  
    0
    Buongiorno Alex,
    non sapevo di dover abilitare questa proprieta'. Comunque l'ho fatto ma l'errore rimane: il codice di errore e' variabile, a volte e' il 2109 a volte il 3021, a volte altri codici ma sostanzialmente il messaggio e' che non trova uno dei due controlli indicati sopra. Faccio presente che altri tasti funzione (F11-F12) a cui sono associati comandi di apertura di maschere funzionano correttamente.

  4. #4
    Post
    1,816
    Like Inviati  
    0
    Like Ricevuti  
    4
    Quote Originariamente inviato da mailman_1969 Visualizza il messaggio
    non sapevo di dover abilitare questa proprieta'.
    Non c'era quella proprietà abilitata ma funzionava lo stesso? Strano. Quello che segue è sulla stessa scia:
    Quote Originariamente inviato da mailman_1969 Visualizza il messaggio
    Comunque l'ho fatto ma l'errore rimane: il codice di errore e' variabile, ....
    Strano, molto strano. Codici errore diversi, prima funzionava tutto, altre cose funzionano.
    Puoi confermare che fino ad un certo punto la stessa cosa che fai adesso funzionava ed ora no?
    Non parlo dell'uso dei tasti funzione e simili ma esattamente quello che stai facendo ora, con gli stessi tasti, nella stessa maschera che ha gli stessi controlli.
    E' meglio vederci chiaro, prova a spiegarti meglio, forse non ho inquadrato bene la situazione

  5. #5
    mailman_1969 non è in linea Scolaretto
    Post
    74
    Like Inviati  
    0
    Like Ricevuti  
    0
    Si', la macro funzionava correttamente nel modo che ho indicato sopra.

    Siccome non so bene quando ha iniziato a non funzionare, faccio una ulteriore precisazione. Mi ricordo di aver testato la funzionalita' di miglioramento prestazioni del database e tra i vari suggerimenti che mi venivano indicati c'era anche quello di convertire le macro in VBA. Che ho fatto.
    Non ricordo pero' se dopo questa "manovra" ha cominciato a dare problemi o se lo faceva anche prima...

    Aggiungo che su un'altra maschera in cui non e' abilitata la proprieta' "Anteprima tasti" o "keypreview" la funzione F11 (apertura di una maschera) funziona correttamente...

  6. #6
    Post
    1,816
    Like Inviati  
    0
    Like Ricevuti  
    4
    Quote Originariamente inviato da mailman_1969 Visualizza il messaggio
    ...Non ricordo pero' se dopo questa "manovra" ha cominciato a dare problemi o se lo faceva anche prima...
    Purtroppo non saprei come aiutarti se non lavorando su un file dimostrativo, quindi che ha quel comportamento ma senza dati riservati. Forse se attendi un po' qualcuno ha qualche idea più tecnica.
    Se scegli la strada del file dimostrativo e non riesci a caricarlo qui devi appoggiarti ad un sito di sharing esterno, Google Drive, OneDrive, DropBox e chi più ne ha più ne metta. La mia personale richiesta in queste situazioni è che non ci sia da iscriversi e che non si debbano fare troppi click tra un banner e l'altro per arrivarci

+ Rispondi al messaggio

Potrebbero interessarti anche ...

  1. Risposte: 7
    Ultimo Post: 13-09-2016, 17:35
  2. Risposte: 14
    Ultimo Post: 06-06-2014, 18:00
  3. Macro di aggiornamento tabella pivot non sempre funzionante
    Da Zannando nel forum Microsoft Excel
    Risposte: 8
    Ultimo Post: 14-01-2014, 00:35
  4. Risposte: 1
    Ultimo Post: 10-01-2014, 21:07
  5. Risposte: 0
    Ultimo Post: 10-01-2014, 18:33