+ Rispondi al messaggio
Pagina 2 di 2 primaprima 12
Visualizzazione dei risultati da 11 a 18 su 18

Inserire un xml in una colonna di una tabella di dbeaver

  1. #11
    Post
    1,901
    Blogs
    21
    Like Inviati  
    14
    Like Ricevuti  
    13
    Quote Originariamente inviato da Nedved9 Visualizza il messaggio
    ...
    inoltre io dovrei inserire l'xml di cui sopra solo dove il campo c_name=StudyID
    ...
    ... devi fare un update allora non una insert ... o sbaglio ?

    Inoltre, anche volessi fare una insert , si vedono molti campi che sono NOT NULL che
    o hanno un valore di default oppure devi valorizzarli nella insert
    ℹ️ Leggi di più su sspintux ...

  2. #12
    Nedved9 non è in linea Scolaretto
    Post
    66
    Like Inviati  
    0
    Like Ricevuti  
    1
    Quote Originariamente inviato da sspintux Visualizza il messaggio
    ... devi fare un update allora non una insert ... o sbaglio ?

    Inoltre, anche volessi fare una insert , si vedono molti campi che sono NOT NULL che
    o hanno un valore di default oppure devi valorizzarli nella insert
    si con la update funziona , però come mai se vado sulla tabella non vedo nulla nel campo c_metadataxml?

    questa è l'update che funziona correttamente
    https://ibb.co/k24pxwh

    però il campo da riempire, nella tabella è ancora vuoto:
    https://ibb.co/4WNPG9v

  3. #13
    Post
    1,901
    Blogs
    21
    Like Inviati  
    14
    Like Ricevuti  
    13
    mi sono perso ; non ci sto capendo più nulla
    ℹ️ Leggi di più su sspintux ...

  4. #14
    Nedved9 non è in linea Scolaretto
    Post
    66
    Like Inviati  
    0
    Like Ricevuti  
    1
    Quote Originariamente inviato da sspintux Visualizza il messaggio
    mi sono perso ; non ci sto capendo più nulla
    Ho semplicemente compiuto un update e non una select come mi ha consigliato e come può vedere dalla foto con l'update funziona, ma non capisco come mai nella tabella il campo sia vuoto..

  5. #15
    L'avatar di _alka_
    _alka_ non è in linea Very Important Person
    Post
    1,399
    Like Inviati  
    0
    Like Ricevuti  
    21
    Quote Originariamente inviato da Nedved9 Visualizza il messaggio
    si con la update funziona , però come mai se vado sulla tabella non vedo nulla nel campo c_metadataxml?
    [...]
    Sei sicuro di aggiornare la riga giusta? Hai rieseguito la query?
    Troppe prove e troppi aggiornamenti, prima una INSERT (con valori NULL richiesti) poi una UPDATE, troppe immagini e poco codice incollato.

    Occorre darsi il tempo di eseguire le operazioni gradualmente, analizzare i problemi e risolverne uno alla volta prima di postare quando si è bloccati definitivamente.
    ℹ️ Leggi di più su _alka_ ...

  6. #16
    Nedved9 non è in linea Scolaretto
    Post
    66
    Like Inviati  
    0
    Like Ricevuti  
    1
    Quote Originariamente inviato da _alka_ Visualizza il messaggio
    Sei sicuro di aggiornare la riga giusta? Hai rieseguito la query?
    Troppe prove e troppi aggiornamenti, prima una INSERT (con valori NULL richiesti) poi una UPDATE, troppe immagini e poco codice incollato.

    Occorre darsi il tempo di eseguire le operazioni gradualmente, analizzare i problemi e risolverne uno alla volta prima di postare quando si è bloccati definitivamente.
    con la update sta funzionando, però come dicevo ,il campo nella tabella rimane vuoto...

    il codice è questo:
    https://ibb.co/7JTgL2G

  7. #17
    Nedved9 non è in linea Scolaretto
    Post
    66
    Like Inviati  
    0
    Like Ricevuti  
    1
    Alla fine ho riavviato l'applicazione e gli xml sono stati inseriti correttamente, vi ringrazio entrambi per le indicazioni e i suggerimenti

  8. #18
    L'avatar di _alka_
    _alka_ non è in linea Very Important Person
    Post
    1,399
    Like Inviati  
    0
    Like Ricevuti  
    21
    Quote Originariamente inviato da Nedved9 Visualizza il messaggio
    Alla fine ho riavviato l'applicazione e gli xml sono stati inseriti correttamente, vi ringrazio entrambi per le indicazioni e i suggerimenti
    Se rieseguivi la query, sicuramente trovavi i dati: i risultati delle query già eseguite non si aggiornano in automatico.
    ℹ️ Leggi di più su _alka_ ...

+ Rispondi al messaggio
Pagina 2 di 2 primaprima 12

Potrebbero interessarti anche ...

  1. come inserire range o colonna
    Da ZUBJFELICE nel forum Microsoft Excel
    Risposte: 6
    Ultimo Post: 15-07-2014, 18:23
  2. Esportare dati tabella in colonna
    Da Enr1 nel forum Microsoft Excel
    Risposte: 26
    Ultimo Post: 08-04-2014, 18:39
  3. Colonna tabella SQL server 2008 con ora sopra le 24
    Da e.manfredi nel forum Microsoft SQL Server
    Risposte: 13
    Ultimo Post: 26-11-2012, 18:39
  4. Risposte: 4
    Ultimo Post: 13-08-2011, 22:17
  5. inserire una colonna textbox in un gridview
    Da massimoflorian nel forum ASP 3, ASP .Net
    Risposte: 1
    Ultimo Post: 12-10-2009, 12:25